Emails do not include custom headers when using the Microsoft Graph API
Some implementations of custom headers cause delivery issues, for example, empty carbon copy (CC) fields in an outbound email.
The header is a code snippet in the HTML email body that precedes the email body. Headers usually contain information about the sender, recipient, and various authentication details.
Condition
Email messages that your application distributes are missing headers.
Cause
This issue might be caused by the following implementation flaws:
- Overridden Service Email rule definition, to enable selecting an unsupported message header type.
- Exceeded the limit for the maximum number of custom headers in a message.
- Formatted the header name improperly.
Solution
- Customize headers by using an activity to send emails. Ensure that your
configuration meets the following requirements:
- The message does not include more than five custom headers.
- The header name has the following format:
"x-<header_ID>"
For more information, see the REST Microsoft Graph API documentation.
- If you use a Service Email rule, for each response header, ensure that
the Field Name parameter value is either
Subject or From.The following figure shows a sample response header in a Service Email rule:
Previous topic Recipients do not receive emails Next topic Unit testing a Service Email rule