Skip to main content


         This documentation site is for previous versions. Visit our new documentation site for current releases.      
 

Pega Robotic Automation application support matrix

Updated on October 18, 2022

In Pega Robotic Automation, Pega Robot Studio and the Studio plug-in support the 32- and 64-bit applications and technologies that are listed in the following table.

Note that adding support for additional applications and technologies is an ongoing process. The following is a list of technologies that Pega Robotic Automation automates by using injection. Other technologies, not listed here, can also be automated. For example, support for Optical Character Recognition (OCR) and Accessibility are included and do not depend on injection techniques. For more information, contact Pega Support.

  • For specific information about Pega Robot Studio and these applications, see the Help for your version of Pega Robot Studio.
  • For information and limitations on individual application version support, see the Release and Build Notes.
  • For more information about system requirements, including a list of the supported versions of Windows, see the Installation Instructions.
Note: In some cases, support for an application or technology can be limited. Accordingly, the links below might provide additional information.

Application / Technology

Pega Robotic Automation version

8.0 SP119.122.1

BeyondTrust

 

Chrome

limited

limited

limited

Citrix server / client

 

Presentation Server 4.5 / ICA Client 10.2

 

 

Presentation Server 4.5 / ICA Client 11.2

 

 

XenApp 5.0 / Online Plug-in 11.2

XenApp 5.0 / Online Plug-in 12.1

XenApp 6.0 / Online Plug-in 11.2

XenApp 6.0 / Online Plug-in 12.1

XenApp 6.5 / Citrix Receiver 12.1 - 14.12

XenApp 7.6 - 7.15 / Citrix Receiver 14.1 and later

XenApp 7.6 - 7.15 / Workspace App 1904.1 and later *

* Refer to the build notes for specific build requirements.

Clarify

version 7.5.0.10 (WoW64)

limitedlimitedlimited

version 12.0.0.0 (WoW64)

limitedlimitedlimited

Console Adapter

limitedlimitedlimited

Control Regions

CyberArk

 

DevExpress

version 3.2.4

limited

limited

limited

version 7.1.2

limited

limited

limited

version 8.3.8

limited

limited

limited

Edge (Chromium)

 limitedlimited

Electron

Version 1.7.9 and up, except for a Server 2012 R2 environment, where Electron 6.0.7 or higher is required.
PNF version 10.1.4.1903 must also be installed to use this feature.

 

Emulators

HLLAPI-compliant, CAIL, Fujitsu, and DOS

limited

limited

limited

Firefox

versions 31 to 39

limited

 

 
versions 52 and laterlimited

limited

 

ESR versions 31.6.0 - 38.3.0

limited  

ESR versions 52 and later

limitedlimited 

Infragistics UltraTree

version 11.1

limited

limited

limited

version 11.2

limited

limited

limited

version 13.2

limited

limited

limited

version 14.1

limited

limited

limited

Internet Explorer *

version 8 x86

 

version 9 x86

 

version 10 x86

 

version 11 x86

version 11 x64

* For more information about supported versions and limitations, see Robotic Automation support for Internet Explorer.

Java *

6 x86

6.0 x64

Java 1.4 x86

Java 5 WoW64

Java 5x86

Java 6 WoW64

Java 6 x86

Java 6 x64

Java 7 (1.7)

Java 8 (1.8)

Java 11

 

* Given the many Java tools and technologies, always test with the tools that you plan to use to discover any additional limitations.

Microsoft Office (64-bit)

Office 365 Apps client (desktop version, not the browser version)

 

Office 2019

 

Office 2016

Office 2013

Office 2010

Microsoft Office (32-bit)

Office 2019

 

Office 2016

Office 2013

Office 2010

Office 2007

 

Office 2003

 

 

Office 2002

 

 

MS Common Controls

V.5 TreeView, status bar

.NET

version 2.0 x86

version 2.0 x64

version 2.0 (WoW64)

version 3.0 x86

version 3.0 x64

version 3.0 (WoW64)

version 3.5 x86

version 3.5 x64

version 3.5 SP1 x86

version 3.5 SP1 x64

version 3.5 (WoW64)

version 4.0

version 4.5

version 4.6

version 4.7.2

 

✔ *

version 4.8

 

✔ *

* Requires build 19.1.51 or later.

PowerBuilder

version 7.0 - 12.5

limited

limited

limited

version 2017

limited

limited

limited

version 19.0

 

limited

limited

version 19.2

 limitedlimited

Remedy

version 7.0.1.11

version 7.0.1.11 (WoW64)

version 7.1.0.7

version 7.1.0.7 (WoW64)

version 7.5

version 7.5 (WoW64)

version 7.6.04.0

SalesForce Lightning *

 

limited

limited

* Included in Pega Robotic Automation 19.1.67 and later. Refer to the build notes for specific limitations.

SAP

version 6.2

version 6.2 (WoW64)

version 7.1

version 7.1 (WoW64)

version 7.2

version 7.2 (WoW64)

version 7.3

version 7.3 (WoW64)

version 7.4

version 7.4 (WoW64)

version 7.5

version 7.7

 

Siebel

version 6.3

limited

limited

limited

version 7.7

version 7.7 (WoW64)

version 7.8

version 7.8 (WoW64)

version 8.0

version 8.0 (WoW64)

version 8.1.11 (Open UI)

For more information, see Using the Siebel Adapter.

Have a question? Get answers now.

Visit the Support Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega.com is not optimized for Internet Explorer. For the optimal experience, please use:

Close Deprecation Notice
Contact us