Source field not displaying in data transform
Valid from Pega Version 7.1.4
On the Data Transform rule form when using the Update Page action, if the Relation value is updated to “with values from”, the Source field will not be displayed.
(Note that for existing data transforms where the Source field has already been completed, this situation should not occur.)
Workaround
- Below is a data transform that has been configured to use Update Page.
- If a user were to choose an alternate source by updating the ‘with values from’ Relation value, they would not be prompted to provide a page name in the Source field.
- At this point, to be able to enter the Source page value, the user has to save the rule, which results in an error because the source page value is blank. This causes the field to appear.
- Once the field has appeared, the Source page value can be provided, and the form can be saved successfully.
WSDL generation error prevents invocation of SOAP services
Valid from Pega Version 8.4.2
Status
A Known Issue was introduced in the 8.4.2 Pega Platform patch release, which impacts both upgrades and new installations of that version.
Description
Due to changes introduced in the SOAP functionality for the case-mismatch error in SR-D98509/INC-119725, the WSDL is being generated for SOAP services with an incorrectly-capitalized element, which prevents the service from being invoked. The element should be “name” instead of “Name”.
Workaround
Clients must perform the following workaround after they define a new SOAP connector in Pega Platform:
- To download the WSDL from Pega Platform:
- After using the SOAP Wizard (Dev Studio > Configure > Integration > Services > Service Wizard) the WSDL URL is shown at the bottom right of the Dev Studio screen.
- Click the URL to display the XML.
- Save the WSDL file to your local system.
- In the text editor of your choice, modify "Name" to "name" in every <element “name” = … > tag in the WDSL.
- Save your changes to the local file.
- To reload the WSDL into Pega Platform:
- In Dev Studio, open the Configure menu.
- Select Integration > Connectors > Create SOAP Integration.
- In the New SOAP integration wizard, select Upload WSDL from File.
- Complete the upload using the wizard prompts.
This is a design-time issue, not a run-time issue; therefore, clients only have to perform this workaround process once. Existing SOAP services should not be impacted; however, if clients modify an existing SOAP service definition by re-running the wizard, clients must reapply the workaround for Pega Platform to recognize the SOAP definition changes.
Resolution
This issue will be addressed in the Pega Platform Patch Release 8.4.3. Clients who upgrade to that version or later should not see this issue.
Search and Reporting does not index large items
Valid from Pega Version 8.5
When using the Search and Reporting (SRS) microservice in Pega Platform™ 8.5, you might encounter problems with indexing large out-of-the-box rules. The issue is not visible in Queue Processors, but you can access logs to verify which items the system does not index.
Tags disappear from Rich Text Editor source mode
Valid from Pega Version 8.5
When you use Rich Text Editor in HTML source mode, some tags disappear from the markup, which causes backward compatibility issues and data loss.
Cause
Pega Platform™ version 8.5.5 introduced the DOM Purifier security plugin. The plugin removes potentially vulnerable tags, including custom tags, from the raw HTML code in the Rich Text Editor source mode.
Workaround
You can disable the DOM Purifier plugin by adding the the window.disableDomPurifier = true
markup to the userWorkForm HTML fragment rule.
Alternatively, as of Pega Platform version 8.5.6, you can add a tag to the allow list by including the window.rteCustomAllowedTags = ['myCustomTag']
snippet in the userWorkForm HTML fragment rule.
In Pega Platform versions 8.5.6 to 8.6, the iframe
tag is added to the allow list by default.